Unity iOS发布应用到AppStore被拒临时解决方案

最近,很多(也可能是所有)使用Unity iOS基于iOS SDK4.3编译的程序在AppStore审核时候得到的结果是程序崩溃不能通过审核,而在开发者的设备上却可以很好的运行.Unity公司对这个事情非常重视并且与苹果进行沟通确认.Unity公司iOS团队正在研究解决方案,但这个问题可能需要较长的时间才能解决.不过目前有个已知的解决方法就是使用iOS SDK4.2及Xcode3.2.5编译构建应用就可以了.

一些用户反馈说(这个问题折磨我够呛,被拒3次,后来我也自己发现用Xcode3.2.5就可以.Xcode3.2.6就不行)使用Xcode3.2.5及SDK4.2即可顺利通过AppStore审核.

不过现在因为SDK4.2没有在开发者网站上公开下载了,但是仍然存在下载连接的.可以从这里下载:”https://developer.apple.com/devcenter/download.action?path=/ios/ios_sdk_4.2__final/xcode_3.2.5_and_ios_sdk_4.2_final.dmg” .Unity iOS支持目前所有版本的iOS设备(3.x~4.2.x版)并且能很好的运行,包括最新的iOS4.3.x版(如iPad2).

如果在发布到AppStore上过程遇到问题.可以随时联系Unity技术团队求助.

转载请注明来自1Vr.Cn
原文来自Unity的邮件.

发布于 :未分类

Unity iOS发布应用到AppStore被拒临时解决方案》有1个想法

发表评论

电子邮件地址不会被公开。